[lkml]   [2006]   [May]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 4/4] Streamline generic_file_* interfaces and filemap cleanups

Nathan Scott wrote:

>Hi Badari,
>On Mon, May 15, 2006 at 02:23:26PM -0700, Badari Pulavarty wrote:
>>This patch cleans up generic_file_*_read/write() interfaces.
>>Christoph Hellwig gave me the idea for this clean ups.
>>In a nutshell, all filesystems should set .aio_read/.aio_write
>>methods and use do_sync_read/ do_sync_write() as their .read/.write
>I know its not something you're introducing here, but the naming
>convention do_sync_read/do_sync_write is pretty confused (with it
>not actually being a sync write and all, in the usual case).
>Any chance that could be renamed to something thats a bit clearer,
>maybe generic_file_non_aio_read and generic_file_non_aio_write?
>There don't seem to be many callsites (so not a huge change) and
>it'd seem a good time to do it, alongside these other changes.

You mean "left-in-pagecache-not-really-written-to-disk" synchronous ?
Yeah. I see it..
I prefer, generic_file_aio_read_and_wait(),
generic_file_aio_write_and_wait() - but
its ugly also :(

I also have a small issue with the current do_sync_*() routines - if
some one calls it
without setting their ->aio_read()/->aio_write(), we panic. May be we
should add a BUG_ON(), but again I don't want to slow things down..


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-05-16 00:49    [W:0.163 / U:4.024 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site