lkml.org 
[lkml]   [2006]   [Mar]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: p4-clockmod not working in 2.6.16
    On Tue, Mar 21, 2006 at 09:55:28PM +0100, Sasa Ostrouska wrote:
    > Hello people,
    >
    > I would like to advise you that in kernel 2.6.16 the
    > p4-clockmod module cant recognise my P4 cpu anymore.
    >
    > This worked perfectly in kernel 2.6.15. I get the following
    > error when I modprobe it:
    >
    > root@rc-vaio:/home/sasa# modprobe msr && modprobe cpuid && modprobe
    > p4_clockmod && modprobe speedstep-lib && modprobe microcode && modprobe
    > hwmon
    > FATAL: Error inserting p4_clockmod
    > (/lib/modules/2.6.16/kernel/arch/i386/kernel/cpu/cpufreq/p4-clockmod.ko): No such device
    >
    > Can somebody explain what happened or how can I set it up ?

    Can you send /proc/cpuinfo and dmesg output please ?
    The only thing that recently changed in p4-clockmod is addition
    of an errata workaround that disables freqs <2GHz on certain CPUs.

    If the max freq is <2GHz this would disable it completely.

    Dave

    --
    http://www.codemonkey.org.uk
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2006-03-21 22:03    [W:0.030 / U:59.172 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site