lkml.org 
[lkml]   [2006]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: libata/sata_nv latency on NVIDIA CK804 [was Re: AMD64 X2 lost ticks on PM timer]
    From
    Date
    On Wed, 2006-03-15 at 22:15 -0500, Bill Rugolsky Jr. wrote:
    >
    > I'm heading home now (it's 22:00, and I've been here 16 hours
    > already), but I figured that I'd post what I have thus far, and
    > perhaps you can tell me what the problem is.
    >

    I think it would be better to try to identify the exact circumstances
    that trigger the large PIO delay, than to start over debugging a new and
    untested driver, especially if the SMM hypothesis has been ruled out.

    You mentioned before the bug only hits with writes to multiple drives -
    can you try to identify a pattern here - stress the drives one at a
    time, try RAID vs. stressing both drives independently, remove one from
    the bus. See if anything affects the duration of the latencies, etc.

    Lots of people have these boards and it seems like if the problem was
    widespread, I would have seen it on the Linux audio lists, as many of
    those users run Ingo's instrumented kernel and they all know to report
    latency traces when they get them.

    Lee

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2006-03-16 05:22    [W:0.019 / U:92.552 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site