[lkml]   [2006]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] for_each_possible_cpu [1/19] defines for_each_possible_cpu
Nick Piggin <> wrote:
> KAMEZAWA Hiroyuki wrote:
> > Now,
> > for_each_cpu() is for-loop cpu over cpu_possible_map.
> > for_each_online_cpu is for-loop cpu over cpu_online_map.
> > .....for_each_cpu() looks bad name.
> >
> > This patch renames for_each_cpu() as for_each_possible_cpu().
> >
> > I also wrote patches to replace all for_each_cpu with for_each_possible_cpu.
> > please confirm....
> >
> > BTW, when HOTPLUC_CPU is not suppoted, using for_each_possible_cpu()
> > should be avoided, I think.
> >
> > all patches are against 2.6.16-rc6-mm1.
> >
> for_each_cpu() effectively is for_each_possible_cpu() as far as
> generic code is concerned. In other words, nobody would ever expect
> for_each_cpu to return an _impossible_ CPU, thus you are just
> adding a redundant element to the name.

We've had various screwups and confusions with these things. I think the
new naming is good - it makes developers _think_ before they use it.
Instead of "I want to touch all the CPUs, gee that looks right" they'll
have to stop and decide whether they want to access the online, possible or
present ones and then they'll (hopefully) have a little think about what
happens when CPUs migrate between those states.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-03-16 05:02    [W:0.066 / U:7.580 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site