[lkml]   [2006]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] for_each_possible_cpu [1/19] defines for_each_possible_cpu
KAMEZAWA Hiroyuki wrote:
> Now,
> for_each_cpu() is for-loop cpu over cpu_possible_map.
> for_each_online_cpu is for-loop cpu over cpu_online_map.
> .....for_each_cpu() looks bad name.
> This patch renames for_each_cpu() as for_each_possible_cpu().
> I also wrote patches to replace all for_each_cpu with for_each_possible_cpu.
> please confirm....
> BTW, when HOTPLUC_CPU is not suppoted, using for_each_possible_cpu()
> should be avoided, I think.
> all patches are against 2.6.16-rc6-mm1.

for_each_cpu() effectively is for_each_possible_cpu() as far as
generic code is concerned. In other words, nobody would ever expect
for_each_cpu to return an _impossible_ CPU, thus you are just
adding a redundant element to the name.

The only places where things might care is arch bootup code, but
the cpu interface is such that the arch code is expected to _hide_
any weird details from these generic interfaces.

SUSE Labs, Novell Inc.
Send instant messages to your online friends

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-03-16 04:46    [W:0.071 / U:1.496 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site