lkml.org 
[lkml]   [2006]   [Dec]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] Add a new section to CodingStyle, promoting include/linux/kernel.h.
On Mon, 18 Dec 2006 12:43:35 -0500 (EST) Robert P. J. Day wrote:

>
> Add a new section to the CodingStyle file, encouraging people not to
> re-invent available kernel macros such as ARRAY_SIZE(),
> FIELD_SIZEOF(), min() and max(), among others.
>
> Signed-off-by: Robert P. J. Day <rpjday@mindspring.com>

Acked-by: Randy Dunlap <randy.dunlap@oracle.com>


> ---
>
> NOTE: at the moment, there is not a single invocation of the
> FIELD_SIZEOF() macro anywhere in the entire source tree, so if someone
> had a hankering to rename it to something more catchy, now would be a
> good time and i can always resubmit the patch i sent in yesterday.
>
>
>
> diff --git a/Documentation/CodingStyle b/Documentation/CodingStyle
> index 0ad6dcb..a736333 100644
> --- a/Documentation/CodingStyle
> +++ b/Documentation/CodingStyle
> @@ -682,6 +682,24 @@ result. Typical examples would be functions that return pointers; they use
> NULL or the ERR_PTR mechanism to report failure.
>
>
> + Chapter 17: Don't re-invent the kernel macros
> +
> +The header file include/linux/kernel.h contains a number of macros that
> +you should use, rather than explicitly coding some variant of them yourself.
> +For example, if you need to calculate the length of an array, take advantage
> +of the macro
> +
> + #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
> +
> +Similarly, if you need to calculate the size of some structure member, use
> +
> + #define FIELD_SIZEOF(t, f) (sizeof(((t*)0)->f))
> +
> +There are also min() and max() macros that do strict type checking if you
> +need them. Feel free to peruse that header file to see what else is already
> +defined that you shouldn't reproduce in your code.
> +
> +
>
> Appendix I: References

---
~Randy
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-12-18 18:59    [W:0.045 / U:3.464 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site