[lkml]   [2006]   [Dec]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: lots of code could be simplified by using ARRAY_SIZE()
Robert P. J. Day wrote:
> On Thu, 14 Dec 2006, Zach Brown wrote:
>> Indeed, there seems to be lots of potential clean-up there.
>> Including duplicate macros like:
>> ./drivers/ide/ide-cd.h:#define ARY_LEN(a) ((sizeof(a) / sizeof(a[0])))
> not surprisingly, i have a script "":

This could also come in the flavor "sizeof(a) / sizeof(*a)".
I haven't checked if there are actual instances.
Stefan Richter
-=====-=-==- ==-- -====
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-12-15 00:17    [W:0.084 / U:3.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site