[lkml]   [2006]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [-mm patch 1/4] GPIO framework for AVR32
On Tue, 7 Nov 2006 12:27:15 +0100
Haavard Skinnemoen <> wrote:

> Add a simple GPIO framework for AVR32. This should be fairly similar
> to the AT91 GPIO API, but there are still a couple of differences:
> * Naming. We prefix all functions with gpio_ instead of at91_
> * request_gpio() and free_gpio() should be called to make sure
> the required pins are available, but it will still work if you
> don't.


I wonder about this naming choice. I'd have though that if/when the kernel
gets a generic GPIO driver or layer, these avr32-specific symbols will need

h8300 uses h8300_free_gpio(), and there's also omap_free_gpio(). Perhaps
this patch should have added avr32_free_gpio()?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-11-07 22:13    [W:0.081 / U:8.612 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site