lkml.org 
[lkml]   [2006]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] HP Mobile data protection system driver with interrupt handling
Date

>From: "Dmitry Torokhov" <dmitry.torokhov@gmail.com>
>To: "Andrew Morton" <akpm@osdl.org>
>CC: "Burman Yan" <yan_952@hotmail.com>, linux-kernel@vger.kernel.org, "Jean
>Delvare" <khali@linux-fr.org>
>Subject: Re: [PATCH] HP Mobile data protection system driver with interrupt
>handling
>Date: Mon, 6 Nov 2006 17:18:53 -0500
>
>On 11/6/06, Andrew Morton <akpm@osdl.org> wrote:
>>On Fri, 03 Nov 2006 18:33:31 +0200
>>"Burman Yan" <yan_952@hotmail.com> wrote:
>> > +
>> > +static unsigned int mouse = 0;
>>
>>The `= 0' is unneeded.
>>
>> > +module_param(mouse, bool, S_IRUGO);
>> > +MODULE_PARM_DESC(mouse, "Enable the input class device on module
>>load");
>
>Does the parameter have to be called "mouse"? I'd rename it to "input"
>and drop the work "class" from parameter description.

Dropping the "class" seems logical, but calling the parameter input
seems confusing to me - to a user that doesn't want to read too much
manual/code and just wants to play around with the device (I do that
sometimes)
mouse sounds more reasonable to me.

>
>> > +
>> > + if (input_register_device(mdps.idev)) {
>> > + input_free_device(mdps.idev);
>> > + mdps.idev = NULL;
>> > + return;
>> > + }
>> > +
>> > + mdps.kthread = kthread_run(mdps_mouse_kthread, NULL, "kmdps");
>> > + if (IS_ERR(mdps.kthread)) {
>> > + input_unregister_device(mdps.idev);
>> > + mdps.idev = NULL;
>> > + return;
>> > + }
>> > +
>
>Please consider implementing mdps_input_open() and mdps_input_close()
>and create and run the polling thread from there - there is no point
>in polling the device if noone listens to its events.

You have a point - I'll see into that.

>
>--
>Dmitry

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today it's FREE!
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-11-07 20:23    [W:0.748 / U:3.912 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site