lkml.org 
[lkml]   [2006]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.6.19-rc6-mm2: uli526x only works after reload
Date
On Thursday, 30 November 2006 02:04, Rafael J. Wysocki wrote:
> On Thursday, 30 November 2006 00:26, Andrew Morton wrote:
> > On Thu, 30 Nov 2006 00:08:21 +0100
> > "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> >
> > > On Wednesday, 29 November 2006 22:31, Rafael J. Wysocki wrote:
> > > > On Wednesday, 29 November 2006 22:30, Andrew Morton wrote:
> > > > > On Wed, 29 Nov 2006 21:08:00 +0100
> > > > > "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> > > > >
> > > > > > On Wednesday, 29 November 2006 20:54, Rafael J. Wysocki wrote:
> > > > > > > On Tuesday, 28 November 2006 11:02, Andrew Morton wrote:
> > > > > > > >
> > > > > > > > Temporarily at
> > > > > > > >
> > > > > > > > http://userweb.kernel.org/~akpm/2.6.19-rc6-mm2/
> > > > > > > >
> > > > > > > > Will appear eventually at
> > > > > > > >
> > > > > > > > ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.19-rc6/2.6.19-rc6-mm2/
> > > > > > >
> > > > > > > A minor issue: on one of my (x86-64) test boxes the uli526x driver doesn't
> > > > > > > work when it's first loaded. I have to rmmod and modprobe it to make it work.
> > > > >
> > > > > That isn't a minor issue.
> > > > >
> > > > > > > It worked just fine on -mm1, so something must have happened to it recently.
> > > > > >
> > > > > > Sorry, I was wrong. The driver doesn't work at all, even after reload.
> > > > > >
> > > > >
> > > > > tulip-dmfe-carrier-detection-fix.patch was added in rc6-mm2. But you're
> > > > > not using that (corrent?)
> > > > >
> > > > > git-netdev-all changes drivers/net/tulip/de2104x.c, but you're not using
> > > > > that either.
> > > > >
> > > > > git-powerpc(!) alters drivers/net/tulip/de4x5.c, but you're not using that.
> > > > >
> > > > > Beats me, sorry. Perhaps it's due to changes in networking core. It's
> > > > > presumably a showstopper for statically-linked-uli526x users. If you could
> > > > > bisect it, please? I'd start with git-netdev-all, then tulip-*.
> > > >
> > > > OK, but it'll take some time.
> > >
> > > OK, done.
> > >
> > > It's one of these (the first one alone doesn't compile):
> > >
> > > git-netdev-all.patch
> > > git-netdev-all-fixup.patch
> > > libphy-dont-do-that.patch

Hm, all of these patches are the same as in -mm1 which hasn't caused any
problems to appear on this box.

So, it seems there's another change between -mm1 and -mm2 that causes this
to happen.

Greetings,
Rafael
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-11-30 21:29    [W:0.113 / U:17.768 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site