lkml.org 
[lkml]   [2006]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Subjectmake oldconfig problem Re: autoconf.h and auto.conf missing
From
Date
On Mon, 2006-11-27 at 23:47 +0100, Lukasz Stelmach wrote:
> Greetings.
>
> It seems that someone has broken *conf programs in 2.6.18 because
> only "make silentoldconfig" recreates autoconf.h and auto.conf
> properly after configuration (.config) has changed.
>
> I do everything as I always have done.
> 1. create an empty dir and put my current .config there
> 2. make O=dir oldconfig
> 3. compile, everything seems to be OK here
> 4. do some changes to .config and make oldconfig once again
> BZZZZZT

yap I have the same problem

to workaround I just do make xconfig and click on save.

I like to have some more input about this ....

Thanks,
> 5. auto.conf and autoconf.h don't change along with .config and when
> I build the kernel once again new settings don't take effect.
>
> I discovered I have to make silentoldconfig to regenerate autoconf
> files. However, this *seems* to force rebuilding of all the objects
> instead of, what it has always done, only those that depend on
> altered configurations.
>
> Has anyone else seen something like this? Is it a bug or a feature?
>
> Best regards,
>
> Please CC, I am not a subscriber.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-11-29 15:23    [W:0.030 / U:15.604 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site