lkml.org 
[lkml]   [2006]   [Nov]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.6.19-rc1-mm1+ memory problem
Short description: when X is loaded (maybe any heavy application is 
sufficient, but I don't use anything heavy in console), 'free' says used
memory is growing.

Keywords: memory.

Kernel: built locally, gcc 4.0.3

I have a strange problem with 2.6.19-rc-mm kernels. After I load X, I
notice that memory is marked used at rate of tens of KB/s. Then it
starts to swap very heavily, when physical memory is all used. I tried
to verify it - it is so with all -mm kernels after 2.6.19-rc1-mm1,
including 2.6.19-rc5-mm2. At the meantime everything works OK with
kernels 2.6.18-mm3 and 2.6.19-rc1 through 2.6.19-rc6. I do not see any
options that should be memory eating in my .config . Module list is
short enough to include inline.

When I just run some things like periodical suck, oops proxy server etc
with X shut down, I do not notice "leak" from console because of small
fluctuations of memory use. When I run X and shut it down, used memory
count goes up a few megs (consistent with speed of eating it by X).

I didn't find exactly this problem in lkml or www, though the problem
with OOM on 2.6.19-rc-mm seems similar.

What should I check to fix problem or produce a useful bug report?

/etc/sysconfig/modules:

ehci-hcd, usb-storage, usbhid, ipaq, i915

Now loaded in 2.6.19-rc6:

i915, drm, ipaq, usbserial, usbhid, usb_storage, libusual, ehci_hcd,
usbcore

Main configuration options:

http://bigtip.narod.ru/temp/xorg.conf.txt
http://bigtip.narod.ru/temp/config-2.6.19-rc2-mm5-swsusp-my-1.txt
http://bigtip.narod.ru/temp/lspci.txt

Drivers:

http://bigtip.narod.ru/temp/ioports.txt
http://bigtip.narod.ru/temp/iomem.txt
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-11-20 07:29    [W:0.094 / U:8.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site