lkml.org 
[lkml]   [2006]   [Nov]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: NFSROOT with NFS Version 3
Hello,

On Fri, 17 Nov 2006 11:20:17 -0500
Trond Myklebust <trond.myklebust@fys.uio.no> wrote:

> On Fri, 2006-11-17 at 16:40 +0100, Christoph Pleger wrote:
> > Hello,
> >
> > I tried to switch an NFSROOT-Environment from NFS version 2 to NFS
> > version 3, but unfortunately my test client machine now hangs every
> > time after booting as soon as some bigger file system activity
> > should occur. I tried Kernel 2.6.14.7 and Kernel 2.6.16.32.
> >
> > The problem did not occur with NFS version 2.
> >
> > Does anybody know the problem and/or a solution?
>
> That is almost always due to the difference in r/wsize that the Linux
> NFS server advertises for v2 and v3 combined with using UDP. If you
> have poor networking, then don't use UDP, and certainly not with 32k
> r/wsize.
>
> IOW: try either setting the mount options "rsize=8192,wsize=8192", or
> the option "proto=tcp"

No, that was not the problem. I tried it, bit it did not help.

Later, I noticed the following message that appeared during the boot
process:

Warning: Unable to open an initial console

So, on the NFS server, I made a copy of the NFSROOT-Directory, exported
the copy read-write (the original is exported read-only) and used the
copy as NFSROOT for the client. And now the client works well.

But now I have two questions:

1. Why did the problem not occur with NFS version 2? On the client,
/dev/console should have been read-only with version 2 as well.
2. What can I do to get a "real" solution? Exporting the original
NFSROOT read-write is not possible for me.

Regards
Christoph Pleger
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-11-20 12:11    [W:0.046 / U:3.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site