[lkml]   [2006]   [Nov]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/4] WorkStruct: Separate delayable and non-delayable events.

On Mon, 20 Nov 2006, Stefan Richter wrote:

> David Howells wrote:
> > Separate delayable work items from non-delayable work items be splitting them
> > into a separate structure (dwork_struct), which incorporates a work_struct and
> > the timer_list removed from work_struct.
> ...
> > if (!delay)
> > - rc = queue_work(ata_wq, &ap->port_task);
> > + rc = queue_dwork(ata_wq, &ap->port_task);
> > else
> > rc = queue_delayed_work(ata_wq, &ap->port_task, delay);
> ...
> A consequent (if somewhat silly) name for queue_delayed_work would be
> queue_delayed_dwork, since it requires a struct dwork_struct.

Yes. Please don't use "dwork" as a name AT ALL. Not in "dwork_struct" and
not in "queue_dwork()".

"dwork" just sounds d[w]orky. More importantly, we don't use short-hand
that isn't obvious, unless there is some industry-standard and old meaning
to it that everybody understands. "delayed_work" may be more typing, but
anybody who needs to type things that fast had better slow down anyway to

No excuses for short and unreadable names.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2009-11-18 23:46    [W:0.070 / U:5.956 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site