lkml.org 
[lkml]   [2006]   [Oct]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Subjectkeyboard scancode problems
From
Date
Hello,

I've a laptop with 2 additional keys for the Euro and Dollar (Acer
TM8106).

When I press these keys, I get the following error:
atkbd.c: Unknown key pressed (translated set 2, code 0xb3 on
isa0060/serio0).
atkbd.c: Use 'setkeycodes e033 <keycode>' to make it known.
atkbd.c: Unknown key released (translated set 2, code 0xb3 on
isa0060/serio0).
atkbd.c: Use 'setkeycodes e033 <keycode>' to make it known.

When I use setkeycodes to link a keycode to a scancode, as shown below:

setkeycodes 0xb3 205

(I think that this is the same as:
setkeycodes e033 205
At least it gives identical results)

To make the key know as Euro key, I do the following:
loadkeys << "EOF"
keycode 205 = currency
EOF

This results in a the Euro sign on my console with
setfont lat0-16 -m 8859-15

Now my question:
When I do a showkey -s, I expect that when I press the Euro key, which
I
just linked to 0xb3 will be shown. But the following is the result:
showkey -s
kb mode was XLATE

press any key (program terminates after 10s of last keypress)...
0x9c
0xe0 0x25
0xe0 0xa5

What is the reason that the scancode which I set differs from what is
shown by showkey?

With kind regards
Joost Gevers



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-10-26 20:07    [W:0.022 / U:9.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site