lkml.org 
[lkml]   [2006]   [Oct]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: UCB1400 driver problem in pxa270
On Fri, 27 Oct 2006, saravanan_sprt@hotmail.com wrote:

> Hi all,
>
> I am a newbie in using UCB1400 chip. Iam using Toradex Colibri module PXA270 as my target system with UCB1400 chip integrated.
> I have a problem in enabling the audio system using UCB1400. Can anyone point me, how could I enable and use the UCB1400 driver on linux 2.6.12 platform. I have applied Nicolas Pitre patches and configured kernel CONFIG_INPUT, CONFIG_SND, CONFIG_SOUND,CONFIG_SND_PXA2xx_AC97, CONFIG_SND_PXA2xx_PCM to =y. The kernel builds well, but on boot the UCB1400 driver didn't gets registered and there are no more interrupts enabled in /proc/interrupts with following boot message,
> .....
> .....
> ts: UCB1x00 touchscreen protocol output
> Advanced Linux Sound Architecture Driver Version 1.0.9rc2 ( The MAr 24 10:34:34 2005 UTC)
> ALSA device list:
> No soundcards found.
> ....
> ....
>
> The problem seems to be due to driver_register(pxa2xx-ac97) and bus match.
>
> Any help will be appreciated .

Look in arch/arm/mach-pxa/mainstone.c for mst_audio_device. This is an
example of the platform_device structure the pxa2xx-ac97 driver is
looking for.


Nicolas
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-10-26 19:17    [W:0.034 / U:13.232 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site