[lkml]   [2006]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: patch [0/2]: acpi: add generic removable drive bay support
On Friday 08 September 2006 16:33, Dave Jones wrote:
> On Fri, Sep 08, 2006 at 01:21:23PM -0700, Kristen Carlson Accardi wrote:
> > On Fri, 8 Sep 2006 20:58:42 +0100
> > Matthew Garrett <> wrote:
> >
> > > > can then be used by udev to unmount or rescan depending on the event. It will
> > > > create a proc entry under /proc/acpi/bay for "eject" and for "status". Writing
> > >
> > > Do we really want it under /proc? It would seem to make more sense for
> > > it to be under /sys.
> >
> > I agree - this is under proc because this is an acpi driver, and the acpi
> > subsystem is still using the /proc fs for driver/user space interface. I
> > thought I would just conform to their standard.
> It's my understanding from talking with Len that he'd like to see /proc/acpi/
> go away over time, so adding more to it seems to be at odds with that goal.

Dave is right. We've had a moratorium on new files under /proc/acpi for some time now.
The reason is that user-space should not know or care that something is supplied
by ACPI -- for on other systems it may be supplied by something else.

So new stuff should have generic names under sys -- even if on a large body of
systems the functionality beneath happens to be supplied via ACPI.

an example of old is the brightness stuff under /proc/acpi and in various platform
specific drivers that scribble under /proc/acpi.
The corresponding example of new is the backlight I/F under /sys.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-10-14 07:15    [W:0.044 / U:2.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site