lkml.org 
[lkml]   [2006]   [Jan]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.15-rc6: known regressions in the kernel Bugzilla
On Mon, Jan 02, 2006 at 05:00:31PM +0100, Adrian Bunk wrote:
> On Fri, Dec 23, 2005 at 12:50:22PM +0100, Gottfried Haider wrote:
> > >>From: "Gottfried Haider" <gohai@gmx.net>
> > >>Subject: [2.6.15-rc2] 8139too probe fails (pci related?)
> > >According to the report perhaps not a post-2.6.14 regression.
> > >But anyways, this should be better debugged.
> > >
> > >@Gottfried:
> > >Does it work with kernel 2.6.14.4?
> > >Does it work with kernel 2.6.15-rc6?
> > >If it stil fails, can you send a complete dmesg for 2.6.15-rc6?
> > I recently played around with this particular system, and it turned out
> > that moving the 8139b-card to another PCI slot fixed it. (works now in both
> > 2.6.15-rc2 and rc6-git2)
> > So I guess it's just a particular oddity of this system, as noone else
> > seems to hit this?
> >
> >
> > the original lines in kern.log were
> > -- snip --
> > PCI quirk: region e400-e47f claimed by ICH4 ACPI/GPIO/TCO
> > PCI quirk: region ec00-ec3f claimed by ICH4 GPIO
> > PCI: Unable to handle 64-bit address for device 0000:01:0c.0
> > PCI: Transparent bridge - 0000:00:1e.0
> > (..)
> > PCI: Cannot allocate resource region 0 of device 0000:01:0c.0
> > PCI: Cannot allocate resource region 3 of device 0000:01:0c.0
> > pnp: 00:03: ioport range 0xe400-0xe47f could not be reserved
> > pnp: 00:03: ioport range 0xec00-0xec3f has been reserved
> > PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
> > PCI: Error while updating region 0000:01:0c.0/3 (fa800800 != 00000810)
> > PCI: Error while updating region 0000:01:0c.0/0 (0000d001 != 813910fc)
> > PCI: Bridge: 0000:00:1e.0
> > (..)
> > 8139too Fast Ethernet driver 0.9.27
> > PCI: Device 0000:01:0c.0 not available because of resource collisions
> > Trying to free nonexistent resource <0000d000-0000d003>
> > Trying to free nonexistent resource <fa800800-fa80080f>
> > 8139too: probe of 0000:01:0c.0 failed with error -22
> > -- snip --
> > .. on a ASUS CUSL2 (i815E) motherboard that was, no change when using
> > pci=routeirq or pci=noacpi.
>
> Greg, can you comment on this issue?

I have no idea, sorry. Glad it's working for you now :)

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-01-04 17:40    [W:0.073 / U:0.584 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site