lkml.org 
[lkml]   [2005]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectlost ticks and Hangcheck
Hi,

I'm running kernel 2.6.12.5 with x86_64 target on an AMD X2 4800+ and
Gigabyte GA-K8NXP-SLI motherboard (bios version F8). I'm having a problem
with lost clock ticks. The dmesg says

warning: many lost ticks.
Your time source seems to be instable or some driver is hogging interupts

Also if I enable hangcheck, then I get a huge number of Hangcheck messages
in dmesg.

The main other symptom is that the system clock runs fast and
inaccurately. It seems to run more inaccurately when I'm using the CPU,
and be basically OK when idling.

I've tried various workarounds that I found suggested on this list and
others but the problem is still there. I tried using noapic, turning on
RTC interrupt, also no_timer_check. I also tried patching the CPU
frequency scaling code with the latest version from the AMD website
(1.50.03), and then finally turning that option off. Nothing helped.

I'm not sure if this is a bug in the kernel or if I'm just doing something
incorrectly. Any thoughts or suggestions, or if is a bug then ETA for a
fix, would be much appreciated.

I'm not a regular subscriber to this list, so please cc any responses
directly to me.

thanks very much,

Nathan
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-08-19 09:43    [W:0.088 / U:7.476 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site