lkml.org 
[lkml]   [2005]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2.6.12.3] PCI/libata INTx cleanup
On Fri, Aug 12, 2005 at 05:44:08PM -0400, Brian Gerst wrote:
> Greg KH wrote:
> >On Fri, Aug 12, 2005 at 01:10:43PM -0400, Brett Russ wrote:
> >
> >>Jeff Garzik wrote:
> >>
> >>>Brett Russ wrote:
> >>>
> >>>
> >>>>Simple cleanup to eliminate X copies of the same function in libata.
> >>>>Moved pci_enable_intx() to pci.c, added pci_disable_intx() as well,
> >>>>and use them throughout libata and msi.c.
> >>>>
> >>>>Signed-off-by: Brett Russ <russb@emc.com>
> >>>
> >>>
> >>>Though there is nothing wrong with this patch, I would prefer a single
> >>>function, pci_intx(), as found in drivers/scsi/ahci.c.
> >>>
> >>>Would you be willing to move that one to the PCI layer, eliminate the
> >>>multiple copies of pci_enable_intx(), and replace the calls to
> >>>pci_enable_intx() with calls to pci_intx() ?
> >>
> >>Sounds like what I did, except for the naming change. I did away with
> >>pci_disable_intx() and changed the names. Look ok?
> >
> >
> >Looks ok to me, care to resend it with a Signed-off-by: and a new
> >changelog entry so I can apply it?
> >
> >
> >>+EXPORT_SYMBOL(pci_intx);
> >
> >
> >Hm, for new pci functions, I prefer to have them marked as
> >EXPORT_SYMBOL_GPL(), is that ok with you?
>
> It's not really "new". It's simply a trivial wrapper around other pci
> functions.

It's a newly exported function.

thanks,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-08-12 23:52    [from the cache]
©2003-2011 Jasper Spaans