lkml.org 
[lkml]   [2005]   [Jul]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[-mm patch] SCSI_QLA2ABC options must select FW_LOADER
[ The subject was adapted to linux-kernel spam filters... ]

On Sat, Jul 16, 2005 at 07:26:44PM +0200, Jindrich Makovicka wrote:
> Andrew Vasquez wrote:
> > Yes, quite. How about the following to correct the intention.
> >
> >
> >
> > Add correct Kconfig option for ISP24xx support.
> >
> > Signed-off-by: Andrew Vasquez <andrew.vasquez@qlogic.com>
> > ---
> >
> > diff --git a/drivers/scsi/qla2xxx/Kconfig b/drivers/scsi/qla2xxx/Kconfig
> > --- a/drivers/scsi/qla2xxx/Kconfig
> > +++ b/drivers/scsi/qla2xxx/Kconfig
> > @@ -39,3 +39,11 @@ config SCSI_QLA6312
> > ---help---
> > This driver supports the QLogic 63xx (ISP6312 and ISP6322) host
> > adapter family.
> > +
> > +config SCSI_QLA24XX
> > + tristate "QLogic ISP24xx host adapter family support"
> > + depends on SCSI_QLA2XXX
> > + select SCSI_FC_ATTRS
>
> there should be also "select FW_LOADER", as it uses request_firmware &
> release_firmware
>...

You are right, patch below.

> Jindrich Makovicka

cu
Adrian


<-- snip -->


qla_init.c now uses code that requires FW_LOADER.

Additionally, this patch removes spaces instead of tabs at the
SCSI_FC_ATTRS selects.

Signed-off-by: Adrian Bunk <bunk@stusta.de>

--- linux-2.6.13-rc3-mm1-full/drivers/scsi/qla2xxx/Kconfig.old 2005-07-17 15:44:26.000000000 +0200
+++ linux-2.6.13-rc3-mm1-full/drivers/scsi/qla2xxx/Kconfig 2005-07-17 15:45:45.000000000 +0200
@@ -1,49 +1,55 @@
config SCSI_QLA2XXX
tristate
depends on SCSI && PCI
default y

config SCSI_QLA21XX
tristate "QLogic ISP2100 host adapter family support"
depends on SCSI_QLA2XXX
- select SCSI_FC_ATTRS
+ select SCSI_FC_ATTRS
+ select FW_LOADER
---help---
This driver supports the QLogic 21xx (ISP2100) host adapter family.

config SCSI_QLA22XX
tristate "QLogic ISP2200 host adapter family support"
depends on SCSI_QLA2XXX
- select SCSI_FC_ATTRS
+ select SCSI_FC_ATTRS
+ select FW_LOADER
---help---
This driver supports the QLogic 22xx (ISP2200) host adapter family.

config SCSI_QLA2300
tristate "QLogic ISP2300 host adapter family support"
depends on SCSI_QLA2XXX
- select SCSI_FC_ATTRS
+ select SCSI_FC_ATTRS
+ select FW_LOADER
---help---
This driver supports the QLogic 2300 (ISP2300 and ISP2312) host
adapter family.

config SCSI_QLA2322
tristate "QLogic ISP2322 host adapter family support"
depends on SCSI_QLA2XXX
- select SCSI_FC_ATTRS
+ select SCSI_FC_ATTRS
+ select FW_LOADER
---help---
This driver supports the QLogic 2322 (ISP2322) host adapter family.

config SCSI_QLA6312
tristate "QLogic ISP63xx host adapter family support"
depends on SCSI_QLA2XXX
- select SCSI_FC_ATTRS
+ select SCSI_FC_ATTRS
+ select FW_LOADER
---help---
This driver supports the QLogic 63xx (ISP6312 and ISP6322) host
adapter family.

config SCSI_QLA24XX
tristate "QLogic ISP24xx host adapter family support"
depends on SCSI_QLA2XXX
- select SCSI_FC_ATTRS
+ select SCSI_FC_ATTRS
+ select FW_LOADER
---help---
This driver supports the QLogic 24xx (ISP2422 and ISP2432) host
adapter family.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2005-07-19 16:15    [W:0.084 / U:2.772 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site