lkml.org 
[lkml]   [2005]   [Jun]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [patch 08/38] CKRM e18: Documentation
Hi!

> > > +CKRM Basics
> > > +-------------
> >
> > Perhaps you want to explain what "CKRM" means?
>
> I'll update this to spell out CKRM a bit more. CKRM stands for
> Class based Kernel Resource Management. I realize that that is a
> bit wordy but early on the team chose to try to be explicit about what
> was being added. And, I'm guessing you really don't want to see
> class_base_kernel_resource_management_number_of_tasks as a structure
> name or class_base_kernel_resource_management_register_classification_engine()
> as a function name. And, while the term class is great for grouping in
> the workload management context, using class_number_of_tasks seems a
> bit presumptious in the kernel naming space.
>
> I'm inclined to leave the name CKRM as is and improve the documentation
> at this point unless you have a more specific solution which can be
> acceptable to all.

I guess that CKRM was used so much that it is acceptable. But I still
liked beancounter as a better name :-) [it was similar project, IIRC].

> > > Index: linux-2.6.12-ckrm1/Documentation/ckrm/rbce_basics
> > > ===================================================================
> > > --- /dev/null 1970-01-01 00:00:00.000000000 +0000
> > > +++ linux-2.6.12-ckrm1/Documentation/ckrm/rbce_basics 2005-06-20 13:08:35.000000000 -0700
> > > @@ -0,0 +1,67 @@
> > > +Rule-based Classification Engine (RBCE)
> > > +-------------------------------------------
> > > +
> > > +The ckrm/rbce directory contains the sources for two classification engines
> > > +called rbce and crbce. Both are optional, built as kernel modules and share much
> > > +of their codebase. Only one classification engine (CE) can be loaded at a time
> > > +in CKRM.
> >
> > TMFLAs! (*)
> >
> > Your resource managment may be quite nice system, but the naming is
> > definitely very ugly. With your design we would not have open() system
> > call, but ofsoarh() -- open filesystem object and return its
> > handle. Can you come up with some reasonable naming?
>
> Can you help? ;) I'd rather not change CKRM itself at this point - too
> many papers and users and such. While it is not impossible, I'm not
> sure that it would help. RCFS seems quite reasonable. RBCE and CRBCE,
> well, I'm much more likely to get excited about better names here.
> ;)

rcfs would be reasonable; unfortunately we already have those /etc/rc*
directories, and rcfs may confuse people into thinking it does
something with system startup. resourcefs?

RBCE/CRBCE are really bad. SimpleClassifier / CustomClassifier?

Pavel
--
Boycott Kodak -- for their patent abuse against Java.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-06-27 23:06    [W:0.047 / U:1.864 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site