lkml.org 
[lkml]   [2005]   [Jun]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: RT patch breaks X86_64 build
Ingo Molnar wrote:
> hm, one difference is that i'm running a 64-bit kernel but 32-bit
> userspace (FC3-ish).

Yes, that's it! I've just successfully booted into 32-bit userspace (I
have a separate partition with old 32-bit Debian) with x86_64 kernel and
LATENCY_TRACE enabled. Everything seemed to work.
Then I mounted my normal root partition under /mnt/64 and tried
chroot /mnt/64
I got a SIGSEGV. Then I copied some simple binaries from /mnt/64/bin to
/root/test/bin and some necessary libraries to /root/test/lib and did
chroot /root/test
I could run 64-bit sash, ls, cat, date, mkdir - it worked. 64-bit bash
however segfaulted.

Michal
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-06-03 00:54    [W:0.058 / U:4.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site