lkml.org 
[lkml]   [2005]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: ALPS touchpad issues still exist in 2.6.12-rc4
From
Date
On Tue, 2005-05-10 at 20:59 -0500, Dmitry Torokhov wrote: 
> > I'm not sure if an updated GPM is the right solution: tapping does very
> > occasionally seem to work (although it might be some facet of the bug
> > that sometimes causes the cursor to appear and select the character
> > beneath it when typing).
>
> I am not sure if I understand what you saying... Are you saying that you
> tried GPM with proper evdev support and you are seeing some issues or that
> you do not believe that GPM should be touched at all?

That was badly phrased ;)
What I meant was "I'm not sure if GPM is the cause of the behaviour I'm
seeing":

With GPM using "-t ps2" on 2.6.12-rc4, phantom clicks are occasionally
generated when typing, which I've never seen happen before. Since
tapping didn't otherwise work during this test, it suggests that
something's not quite right...

I'm currently using GPM 1.20.1 - which I believe is the latest release -
which does allow "-t evdev". Does this need any special configuration
over any other protocol?

> > More than this, with every kernel (at least since the very early 2.4
> > ones) up to 2.6.10 the ALPS touchpad has worked just fine through
> > input/mice or the psaux device - why has this changed in 2.6.11,
>
> Because some people do not want tapping and some people do not like
> default sensitivity and some like having virtual scrolling while other
> want to have different actions assigned to corner taps.

Perhaps it might be prudent in this case to make the default behaviour
in 2.6.11+ kernels the same as previous kernels?

> > and can the change be reverted before 2.6.12 is released?
>
> You do not need to wait for 2.6.12:
>
> modprobe psmouse proto=exps
>
> or boot with "psmouse.proto=exps" if mouse is built as a module.
>
> On a bit tangent note - anyone is willing to test resync patches? I do not
> have access to ALPS touchpad and that's the one piece of hardware that does
> not want to play nicely...

Ah - I tried using "psmouse.proto=exps2" as a kernel argument before
(with 2.6.11?) and it didn't fix things completely. This has changed
though, and you're right that in 2.6.12 this completely restores the
original behaviour.

I'm also happy to test any further ALPS patches, if needs be...

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-05-11 20:44    [W:0.054 / U:6.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site