lkml.org 
[lkml]   [2005]   [Apr]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: init process freezed after run_init_process
>> Make your own initrd and put a bash into it. Then start that, e.g. (for
>> our linux live cd), initrd=initrd.sqfs root=/dev/ram0 init=/bin/bash
>
> I have tried these kernel parameters:
> init=/bin/bash
> init=/linuxrc
> init=/init
> init=/sbin/init
> None works.

What's the error message?

> Also, after some google, I found that the format of initrd has changed.
> I also tried a new initrd with cpio format. The kernel recognized it:

cpio initrd's (aka initramfs) are new - the "old style" initrd where you
`mksquasfs mydir initrd.sqfs` (see above) continues to work, though.

> After the kernel start, I add breakpoints at cpu_idle and do_schedule.
> cpu_idle never reached, only do_schedule did. Is that strange?

Until pid 1 is started, the cpu should never be idle.


Jan Engelhardt
--
No TOFU for me, please.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-04-08 19:56    [W:0.044 / U:1.780 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site