lkml.org 
[lkml]   [2005]   [Apr]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: init process freezed after run_init_process
> Apply these rules:
> 1.) If you do provide an initrd= thing, the initrd is being looked for
> /linuxrc.

I have add /linuxrc, /init and /bin/init, all link to /sbin/init.
It just refuses to work ... :(

> Only VIA IDE chipset maybe, but you don't usually need that for just-initrd.
> You'd need that for the harddisks...

My harddisk works fine without initrd.

>
> Make your own initrd and put a bash into it. Then start that, e.g. (for our
> linux live cd), initrd=initrd.sqfs root=/dev/ram0 init=/bin/bash

I have tried these kernel parameters:
init=/bin/bash
init=/linuxrc
init=/init
init=/sbin/init
None works.

Also, after some google, I found that the format of initrd has changed.
I also tried a new initrd with cpio format. The kernel recognized it:
Boot Logs:
1) checking if image is initramfs... it is
Freeing initrd memory: 17583k freed
2) loading drivers
3) Freeing unused kernel memory: 128k freed

After the kernel start, I add breakpoints at cpu_idle and do_schedule.
cpu_idle never reached, only do_schedule did. Is that strange?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-04-08 04:41    [W:0.058 / U:1.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site