lkml.org 
[lkml]   [2005]   [Apr]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [bk tree] DRM add a version check.. for 2.6.12 (distro kernel maintainers + drm users plz read also...)
Dropping Linus off this list...

On Mon, Mar 28, 2005 at 12:40:16PM +0100, Dave Airlie wrote:
> Hi Linus,
>
> In order to stop someone loading a drm driver on a wrong core this patch
> makes the driver pass in the version is was built against, this mainly
> useful for people using the DRI snapshots for cards that aren't their
> normal cards...
>
> Also for anyone who maintains a kernel for distros or builds their own
> please build your kernels with CONFIG_DRM=m not =y, from 2.6.11 onwards..
> as if you build with =y then DRI snapshots will no longer work..

I tried 2.6.12-rc2 which includes this patch, and I get DRM failures
here, which causes application and X to hang. (I got failures with 2.6.11
also.)

When accessing the machine from network, I can see that either application,
or X itself is running as close as possible to 100% CPU utilization.

Symptom is such that the application, or X-server, is executing an ioctl()
on a file-handle that has node: /dev/drm/card0 open in r/w mode.

Following is from memory:

ioctl(5, something, something)
-- Received ALARM(0) --
ioctl(5, something, something)
-- Received ALARM(0) --

that repeats as fast as possible.

I have now Radeon 9200SE card with 128 MB memory (I used to have Matrox
MGA G400 AGP with 8 MB memory - no room for anything but pixel maps), but
then I absolutely needed accelerated 3D, and had to go and get a "modern"
card.

System is running Fedora Core 4 Test-1 application space codes along
with fresh baseline 2.6.11 + 2.6.12-rc2 patchset ( = "2.6.12-rc2" ).


I observed that xscreensaver-demo running "GLForestFire" is reliably
able to hangup the desktop within minutes, IF media-automounter is
snooping around in /dev/cdrom and there is some disk. (I had FC4test1
rescue disk in there. )

With disk taken out, the system ran some 8 hours without a glitch.

Nevertheless, I then tried some fun with TuxRacer, and was able to
get the same drm hangup after an hour or so.


ANY ideas ?

/Matti Aarnio
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-04-07 13:53    [W:0.039 / U:7.724 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site