lkml.org 
[lkml]   [2005]   [Apr]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.12-rc2-mm1: ACPI=y, ACPI_BOOT=n problems
Adrian Bunk wrote:
> On Wed, Apr 06, 2005 at 12:32:52AM +1200, Reuben Farrelly wrote:
>
>>Hi again
>>
>>At 12:14 a.m. 6/04/2005, Adrian Bunk wrote:
>>
>>>On Tue, Apr 05, 2005 at 08:34:11PM +1200, Reuben Farrelly wrote:
>>>
>>>
>>>>Hi,
>>>
>>>Hi Reuben,
>>>
>>>
>>>>...
>>>>Hrm. Something changed between the last -mm release which compiled
>>>>through, and this one..
>>>>...
>>>> LD .tmp_vmlinux1
>>>>arch/i386/kernel/built-in.o(.init.text+0x1823): In function `setup_arch':
>>>>: undefined reference to `acpi_boot_table_init'
>>>>arch/i386/kernel/built-in.o(.init.text+0x1828): In function `setup_arch':
>>>>: undefined reference to `acpi_boot_init'
>>>>make: *** [.tmp_vmlinux1] Error 1
>>>>[root@tornado linux-2.6]#
>>>>
>>>>Backing out bk-acpi.patch works around it..
>>>
>>>Please send your .config .
>>
>>Have just figured out that it seems to be caused by having ACPI
>>disabled in .config, once I re-enabled ACPI the build problem went away.
>>
>>Config attached anyway, I imagine the problem is quite reproduceable..
>
>
> Ah, this was the working .config .
> fter setting CONFIG_ACPI=n I started seeing different but most likely
> related problems.
>
>
> @Len:
> ACPI=y and ACPI_BOOT=n seems to be a legal configuration (with
> X86_HT=y), but it breaks into pieces if you try the compilation.
>

Here is some additional and hopefully helpful information.
Without CONFIG_ACPI=y, I first got:

arch/i386/kernel/setup.c: In function 'setup_arch':
arch/i386/kernel/setup.c:1571: warning: implicit declaration of function 'acpi_boot_table_init'
arch/i386/kernel/setup.c:1572: warning: implicit declaration of function 'acpi_boot_init'

and then at the end:

arch/i386/kernel/built-in.o(.init.text+0x1b81): In function `setup_arch':
: undefined reference to `acpi_boot_table_init'
arch/i386/kernel/built-in.o(.init.text+0x1b86): In function `setup_arch':
: undefined reference to `acpi_boot_init'
make: *** [.tmp_vmlinux1] Error 1

With these set linux-2.6.12-rc2-mm1 built OK.

[steven@spc1 linux-2.6.12-rc2-mm1]$ grep ^CONFIG_ACPI .config
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_INTERPRETER=y
CONFIG_ACPI_BLACKLIST_YEAR=0
CONFIG_ACPI_BUS=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_SYSTEM=y

Steven
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-04-06 13:31    [W:0.094 / U:2.508 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site