lkml.org 
[lkml]   [2005]   [Apr]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Device Node Issues with recent mm's and udev
On Thu, Apr 28, 2005 at 12:57:46AM -0400, Joe wrote:
> On 4/28/05, Greg KH <greg@kroah.com> wrote:
> > Is the device "disappearing" and then the udev deletes the device node,
> > and then dd starts dumping data to a file instead?
> >
> > Anything in your kernel log when this happens?
> >
> > Does this happen with 2.6.12-rc3?
> >
> > thanks,
> >
> > greg k-h
> >
>
> I've checked the kernel logs and was unable to find anything
> suspicious. This does not seem to happen on vanilla, its a mm only
> issue.
>
> The device becomes a regular file, and udev seems to forget about it..

That implies that udev got a hotplug event that told it to delete the
node.

Any kernel log entries? Is the device in usb or firewire mode?

> even if I replug in the device, udev will not touch this file.

That's because the file is not a node, and udev will not overwrite that.

> It also seems to have trouble recreating the node even when the file
> has been deleted

"trouble" how?

thanks,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-04-28 07:09    [W:0.031 / U:30.264 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site