[lkml]   [2005]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] rename rw_verify_area() to rw_access_ok()
On Wed, 20 Apr 2005, Marcelo Tosatti wrote:

> On Sun, Apr 17, 2005 at 11:50:35PM +0200, Jesper Juhl wrote:
> > verify_area() will soon be dead and gone, replaced by access_ok(), thus
> > the function named rw_verify_area() is badly named and should be renamed.
> > This patch renames rw_verify_area to rw_access_ok which seems more
> > appropriate (it also updates all callers of the functions as well as
> > references to it in comments).
> Not that I care too much, but, rw_verify_area() has nothing to do with
> verify_area/access_ok functions.
right, access_ok deals with memory, rw_verify_area deals with files, but
both serve a similar purpose - validating access to a region. That's why I
thought it would make sense to have them named similarly (as they used to

> I dont see real need to rename this function.
Perhaps I went a tad too far, or perhaps I misunderstood the point of
rw_verify_area(), that's certainly a possibility. In any case, it's no big
deal, I just thought it was the logical thing to do - I'll leave it in
Andrews capable hands to decide.

Thank you for commenting.

Jesper Juhl

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-04-20 22:23    [W:0.042 / U:16.536 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site