lkml.org 
[lkml]   [2005]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
Subjecti830 lockup
From
Hello,

I am developing a device driver for the AxiomTek AX5621H data
acquisition card, and I am encountering some problems on a particular
machine. This driver works pretty fine on normal machines, but crashes
on an Industrial PC with intel 830 2-piece board (with the main board
going into a PCI and an ISA slot on the expansion board(which houses
all the PCI, ISA and AGP slots) at the same time. The error I get is
given below :

CPU 0 : Machine Check Exception : 0000000000000004
Bank 0 : a200000084010400
Kernel panic : CPU context corrupt
In interrupt handler - not syncing

The DMA channel I use is DMA1, and i check for free interrupts and then
allocate them accordingly. So there is no conflicts, I assume. Also there
are no conflicts on the address range I have allocated (It is for now
0x300). The card supports only DMA channels 1 and 3. I have tried both, to
the same result. If anyone among you have had experience with such a
problem, any help in fixing this matter would be of great help.


Thank You.
Harish Harshan.


-----------------------------------------
This email was sent using Amrita Mail.
"Amrita Vishwa Vidyapeetham [Deemed University] - Amritapuri Campus"
http://amritapuri.amrita.edu

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-04-20 08:34    [W:0.075 / U:16.208 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site