lkml.org 
[lkml]   [2005]   [Mar]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: 2.6.12-rc1-mm3: class_simple API
From
Date
On Sun, 27 Mar 2005 13:04:31 EST, Nick Orlov said:

> Problem is that the latest bk-driver-core patch included in the 2.6.12-rc1-mm3
> removes class_simple API without providing EXPORT_SYMBOL'ed (as opposed to
> EXPORT_SYMBOL_GPL) alternative.
>
> As the result I don't see a way how out-of-the-kernel non-GPL drivers
> (nvidia in my case) could be fixed.

Umm.. try running the latest drivers?

[~]2 uname -a
Linux turing-police.cc.vt.edu 2.6.12-rc1-mm3 #1 PREEMPT Sat Mar 26 22:07:50 EST 2005 i686 i686 i386 GNU/Linux
[~]2 lsmod | grep nvidia
nvidia 3912636 14
agpgart 25672 2 nvidia,intel_agp
[~]2 grep -i nvidia /var/log/kernmsg
Mar 30 21:58:19 turing-police kernel: [4294721.402000] nvidia: module license 'NVIDIA' taints kernel.
Mar 30 21:58:19 turing-police kernel: [4294721.434000] NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7167 Fri Feb 25 09:08:22 PST 2005
(All usual disclaimers about binary modules apply. If 7167 doesn't work for
you, bug NVidia (Zander is usually quite helpful with providing patches) and/or
check the NVidia/Linux message boards (there's a link on the NVidia driver
download page).

[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-04-06 13:31    [from the cache]
©2003-2011 Jasper Spaans