lkml.org 
[lkml]   [2005]   [Mar]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    SubjectRe: Problems with SCSI tape rewind / verify on 2.4.29
    On Wed, Mar 02, 2005 at 11:15:42AM -0000, Mark Yeatman wrote:
    > Hi
    >
    > Never had to log a bug before, hope this is correctly done.
    >
    > Thanks
    >
    > Mark
    >
    > Detail....
    >
    > [1.] One line summary of the problem:
    > SCSI tape drive is refusing to rewind after backup to allow verify and
    > causing illegal seek error
    >
    > [2.] Full description of the problem/report:
    > On backup the tape drive is reporting the following error and failing
    > it's backups.
    >
    > tar: /dev/st0: Warning: Cannot seek: Illegal seek
    >
    > I have traced this back to failing at an upgrade of the kernel to 2.4.29
    > on Feb 8th. The backups have not worked since. Replacement Drives have
    > been tried and cables to no avail. I noticed in the the changelog that a
    > patch by Solar Designer to the Scsi tape return code had been made.

    v2.6 also contains the same problem BTW.

    Try this:

    --- a/drivers/scsi/st.c.orig 2005-03-02 09:02:13.637158144 -0300
    +++ b/drivers/scsi/st.c 2005-03-02 09:02:20.208159200 -0300
    @@ -3778,7 +3778,6 @@
    read: st_read,
    write: st_write,
    ioctl: st_ioctl,
    - llseek: no_llseek,
    open: st_open,
    flush: st_flush,
    release: st_release,
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/
    \
     
     \ /
      Last update: 2005-03-22 14:10    [W:0.042 / U:297.272 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site