[lkml]   [2005]   [Dec]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: ide-cd doesn't replace ide-scsi?
    Luke-Jr wrote:
    > On Monday 28 November 2005 21:03, you wrote:
    >>Luke-Jr wrote:
    >>>Note: results are with 2.6.13 (-gentoo-r4 + supermount) and 2.6.14
    >>>(-gentoo) I've been struggling with burning DVD+R DL discs and upgrading
    >>>the firmware on my DVD burner, and just today decided to rmmod ide-cd and
    >>>try using ide-scsi. Turns out it works... so is ide-cd *supposed* to
    >>>handle cases other than simple reading and burning or is this a bug? If
    >>>not a bug, should ide-scsi really be marked as deprecated?
    >>>Also, two bugs with ide-scsi:
    >>>1. On loading the module, it detects and allocates 6 SCSI devices for a
    >>>single DVD burner (Toshiba ODD-DVD SD-R5272); kernel log for this event
    >>>attached 2. On attempted unloading of the module, rmmod says 'Killed' and
    >>>the module stays put, corrupt. There was some kind of error in dmesg, but
    >>>it appears to have avoided syslog-- If I see it again, I'll save it.
    >>I think you may have the probe-all-LUNs set, and a CD burner which
    >>responds to more than one. That's one possible cause for this.
    > Yep, it was set. I'll try turning it off.
    >>Unfortunately using ide-cd still doesn't have the code set to allow all
    >>burning features to work if you are not root. Even if you have read+write
    >>there's one command you need to do multi-session which is only allowed to
    >>root. Works fine for single sessions, I guess that's all someone uses.
    > I'm pretty sure I tried doing everything as root days before I even considered
    > ide-scsi... In regards to firmware upgrades, I wouldn't expect non-root to be
    > allowed to, even with rw access.

    Actually, a single session burn seems to work (I'm doing tests as soon
    as I get a compile of the latest kernel). What doesn't (or didn't) work
    is multisession, even with r/w "cdrecord -msinfo" fails, which is how
    you get the starting info for the next session.
    >>Haven't tried unloading the module, so I have no advice on that other than
    >>"don't do that."
    > Well, I had reasons... =p
    > The first time, I was going to switch back to ide-cd (for DMA), and the second
    > time was because the drive was stuck on Busy and I'm not sure of any (other?)
    > way to reset it without hotplugging the IDE power cable (which I'm sure isn't
    > a good idea and I don't want to risk).

    I thought ide-scsi now did DMA, at least for data burns. Don't know
    about audio, I occasionally do an audio burn, but my main machine for
    burning uses ide-cd, so it's not an issue.

    I saw a note somewhere about using capabilities on the cdrecord
    executable to allow the realtime sched to be set, but I don't seem to
    find it now. Maybe it was a question rather than an example :-(

    bill davidsen <>
    CTO TMR Associates, Inc
    Doing interesting things with small computers since 1979
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-12-02 17:23    [W:0.024 / U:9.372 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site