[lkml]   [2005]   [Dec]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
On Tue, Dec 13, 2005 at 10:48:19AM +0000, David Howells wrote:
> > > +#define is_mutex_locked(mutex) ((mutex)->state)
> >
> > Let's keep the namespace consistent. mutex_is_locked().
> But that's a poor name: it turns it from a question into a statement:-(

Ah, but look at it in context of how it's used:

if (is_mutex_locked())
That's gramatically incorrect!

if (mutex_is_locked())
much better.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-12-13 13:42    [W:0.185 / U:1.372 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site