lkml.org 
[lkml]   [2005]   [Nov]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [Fastboot] kdump's dump capture kernel fails (APICs & linux-2.6.15-rc1)
    From
    Date
    On Mon, 2005-11-21 at 00:46 +0900, Fernando Luis Vazquez Cao wrote:
    > Hi Eric,
    >
    > It seems there are still some problems with the initialization of the
    > APICs in the second kernel. As you can see from the serial line captures
    > below, early during the boot process the kernel is flooded with
    > "unexpected IRQ trap at vector ##" errors and fails to boot.
    >
    > Some basic details about the machine:
    > - Dual Xeon Hyper-Threading 2.4GHz
    > - 1GB RAM
    >
    > In this particular machine the problem could be solved by reintroducing
    > the APICs shutdown patch. The drawback with this approach is that
    > LAPIC/IOAPIC registers setup for the legacy PIC mode differs a lot
    > between mother boards and the somewhat hackish shutdown code fails to
    > set the APICs properly under certain configurations.

    I have just realized that the "move apic init in init_IRQs" patches by
    Eric were reverted back. Besides, APICs shutdown code made it back into
    linux-2.6.15-rc2.
    This is a desirable stopgap solution that will solve the problem for
    some machines and configurations.

    Anyway, up to now, the "LAPIC/IO-APIC save/restore" solution is the only
    one that has worked reliably for us (even with badly broken BIOSes).

    I will test Eric's patches and report the results.

    Regards,

    Fernando

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-11-21 08:30    [W:0.024 / U:1.512 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site