[lkml]   [2005]   [Oct]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [swsusp] separate snapshot functionality to separate file

> > Split swsusp.c into swsusp.c and snapshot.c. Snapshot only cares
> > provides system snapshot/restore functionality, while swsusp.c will
> > provide disk i/o. It should enable untangling of the code in future;
> > swsusp.c parts can mostly be done in userspace.
> >
> > No code changes.
> I think that the functions:
> read_suspend_image()
> read_pagedir()
> swsusp_pagedir_relocate() (BTW, why there's "swsusp_"?)
> check_pagedir() (BTW, misleading name)
> data_read()
> eat_page()
> get_usable_page()
> free_eaten_memory()
> should be moved to snapshot.c as well, because they are in fact
> symmetrical to what's there (they perform the reverse of creating
> the snapshot and use analogous data structures). IMO the code
> change required would not be so drammatic and all of the functions
> that _operate_ on the snapshot would be in the same file.

No. read_suspend_image/read_pagedir/data_read is image reading. That
does not belong to snaphost. The rest is notthat clear, but I have it
working in userspace.

Image creation is still done in kernel space, but I think that kernel
<-> user interface is going to be cleaner that way, and I do not think
pushing it to user is so huge win.

Yes, names are not ideal, but that will be followup patch.
if you have sharp zaurus hardware you don't need... you know my address
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-10-04 01:20    [W:0.101 / U:1.028 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site