[lkml]   [2005]   [Jan]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: 2.6.11-rc2-mm1: fuse patch needs new libs

> > >As I personally like for my ls to keep on working, and I assume
> > >others will, too, I would appreciate it if you could add a
> > >warning to your announcements the following one or two weeks or
> > >so, so that people can remove this patch if they don't want to
> > >update their libs.
> >
> > By any chance would this also break perl programs which readdir?
> Of course; I haven't tested it, but the actual ioctls aren't working
> anymore, so it's not even _possible_ to get them to work with this
> patch and an old version of the fuse libs, even with perl bindings,
> which go through the fuse libs anyway.

First, a little clarification: FUSE doesn't use ioctl() for
communication between the kernel and userspace. It uses read() and

That aside, you are right, that this change breaks any kind of FUSE
based filesystem. However the fix is trivial: install FUSE version
2.2-pre5 or later. The filesystems themselves don't need to be
rebuilt, since the fix in the shared library will automatically get


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:09    [W:0.164 / U:1.016 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site