Messages in this thread |  | | Date | Sun, 5 Sep 2004 11:00:32 -0400 | | From | Greg KH <> | | Subject | Re: Backlight and LCD module patches [2] |
| |
On Sat, Aug 21, 2004 at 02:51:33AM +0000, John Lenz wrote: > > Here. A few notes on the implementation. I have a global lock protecting > all match operations because otherwise we get a dining philosophers problem. > (Say the same class is in two class_match structures, class1 in the first > one and class2 in the second...)
You also have some duplicated code in one function, which implies that you didn't test this patch (it's in the updated patch you sent me too) :)
> The bigger question of how should we be linking these together in the first > place?
I thought you only wanted the ability to actually find the different class devices. Then the code would take it from there. Not this complex driver core linking logic that you implemented.
> Instead of using this class_match stuff, we could use class_interface.
Exactly. Why don't you all use that instead?
thanks,
greg k-h - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
|  |