[lkml]   [2004]   [Sep]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: 2.6.8 link failure for powerpc-970?

    > Sure. For ppc64, beyond allnoconfig, I had to enable
    > ... um, but that didn't fix everything. Now it fails with

    OK, I guess we need some better wrapping of compat code.

    > Um, why is it using the host's gcc? I ran make with
    > make V=1 ARCH=ppc64
    > CROSS_COMPILE=/opt/crosstool/powerpc64-unknown-linux-gnu/gcc-3.4.2-glibc-2.3.3/bin/powerpc64-unknown-linux-gnu-
    > so it really should know better, shouldn't it?

    Check out arch/ppc64/boot/Makefile, in particular CROSS32_COMPILE. The
    boot wrapper is a 32bit binary.

    Now that the toolchain is biarch capable we could get rid of that and
    use gcc -m32 instead. But for the moment specify a CROSS32_COMPILE ant
    things should link.

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:06    [W:0.021 / U:11.076 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site