lkml.org 
[lkml]   [2004]   [Aug]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectPacket writing problems
From
Date
I'm trying to do packet writing with my new DVD writer.

# cat /proc/ide/hdc/model
PIONEER DVD-RW DVR-107D

dma enabled.
After some tests with 2.4 I decided to switch to 2.6.
I used Fedora Core 2 with a vanilla kernel 2.6.8.1 + patch from
http://w1.894.telia.com/~u89404340/patches/packet/2.6/, udftools with
Petero patch (http://w1.894.telia.com/~u89404340/patches/packet/, same
site and author).

However I get a lot of problems mount/unmounting devices...

DVD+RW
mkudffs /dev/hdc does not works... doing a strace opening /dev/hdc for
read/write open returns EROFS (or similar). I tried with blockdev
--setrw but still same errors... Than I used pktsetup. mkudffs with
packet device (/dev/pktcdvd/test) worked so I mounted it (still /dev/hdc
report readonly so I used /dev/pktcdvd/test). I copied a directory (4
MB) an deleted it. Then I unmounted device and then waited... after a
while DVD led turned off and DVD spin down... umount command still not
exited... I waited 20 minutes but still hangs so I restarted my PC.

DVD-RW
After a lot of tests I realized that I have to use dvd+rw-format with
-force=full cause DVD was not empty. Then I used pktsetup and mkudffs
(with no problem). I tried to mount my DVD but mount (not umount) hangs.
Using ps it seems than mount call wait_to_buffer. After 10/15 minutes I
restarted my PC...

I have also a SCSI CD recorder (Waitec WT4260) and a CDRW formatted with
UDF (using 2.4.23 and an old patch from Petero site) and it works
without problems... Is the problem related to IDE or to DVD ??

I'm not (still :) ? ) a linux guru and I don't know how to debug or what
check should I execute... Should I send my .config ? Stop some daemons ?
Work without X ?

freddy77


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:05    [W:0.046 / U:2.812 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site