lkml.org 
[lkml]   [2004]   [Aug]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH] Fix for ALSA AC'97 Init not working in post 2.6.7 mm-kernels
On Wed, 11 Aug 2004, Stefan Schweizer wrote:

> Hi,
>
> I noticed that my soundcad stopped working in the mm-kernels after 2.6.7.
> The kernel log produces this message:
>
> AC'97 0 does not respond - RESET
>
> I grepped for it in the mm-patch and reverted the mm-changes there,
> that fixed it for me.

Could you try this patch?

Index: ac97_codec.c
===================================================================
RCS file: /cvsroot/alsa/alsa-kernel/pci/ac97/ac97_codec.c,v
retrieving revision 1.143
diff -u -r1.143 ac97_codec.c
--- ac97_codec.c 10 Aug 2004 11:19:16 -0000 1.143
+++ ac97_codec.c 11 Aug 2004 18:43:00 -0000
@@ -1898,7 +1898,7 @@
else {
err = ac97_reset_wait(ac97, HZ/2, 0);
if (err < 0)
- err = ac97_reset_wait(ac97, 0, 1);
+ err = ac97_reset_wait(ac97, HZ/2, 1);
}
if (err < 0) {
snd_printk(KERN_WARNING "AC'97 %d does not respond - RESET\n", ac97->num);
Jaroslav

-----
Jaroslav Kysela <perex@suse.cz>
Linux Kernel Sound Maintainer
ALSA Project, SUSE Labs
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2005-03-22 14:05    [W:0.038 / U:4.696 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site