[lkml]   [2004]   [Jul]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [patch] voluntary-preempt-2.6.8-rc2-L2 PS2 keyboard gone south
On Fri, 2004-07-30 at 17:31, Shane Shrybman wrote:
> On Fri, 2004-07-30 at 14:03, Lee Revell wrote:
> > On Fri, 2004-07-30 at 10:06, Shane Shrybman wrote:
> > > Twice while using -L2 my IBM PS2 keyboard has become completely
> > > non-responsive. USB mouse and everything else seems to be fine, but no
> > > LEDs or anything from the keyboard.
> > >
> > > On both occasions the last key I hit on the keyboard was numlock and the
> > > numlock did not come on and I had to reboot after that.
> > >
> > > UP, x86, gcc 2.95, scsi + ide, bttv
> > >
> >
> > This happened to me, also twice necessitating a reboot. I am pretty
> > sure I did *not* hit Num Lock last, though the system was under load -
> > multiple builds going on, jackd running, and video playback. I tried to
> > toggle Num Lock to see if the machine was really locked hard, and it
> > worked for a while (though it did not go on/off exactly once for each
> > time I hit it), then stopped responding.
> >
> Did this happen with both the rc2-L2 and rc2-M5 kernels for you too?

Have not tried M5 yet (still building). An improved fix was posted for
the PS/2 problem recently which uses a semaphore and work queues rather
than Ingo's original quick fix of just adding a lock-break. If the
problem is indeed keyboard-related, this may help.

I also have not determined whether the system freezes completely or
whether it is just the input layer that hangs. Next time this happens I
will try to ssh in.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:04    [W:0.049 / U:6.844 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site