lkml.org 
[lkml]   [2004]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Video memory corruption during suspend
    Hi!

    > My setup is:
    > ASUS L3800C laptop, Radeon M7, i845 chipset, using DRI and radeonfb.
    >
    > Note that this is not specific to the kernel used, as I've been seeing
    > similar corruption every now and then, most recently under 2.6.7 +
    > ACPICA20040715 + swsusp2.0.0.100 (S3, S4), but also under 2.4 with S1 (but
    > not with S4/swsusp2).
    >
    > I have a very simple script I use to suspend (i.e. basically echo $arg >
    > /proc/acpi/sleep), which is usually started by acpid. Once the script is
    > triggered (by pressing power / sleep button) and an X session is running,
    > various red and green patches appear on the screen (the background image
    > and the tinted terminal emulator), followed by the VT switch the PM code
    > does. After resume and subsequent VT switch by the PM code the corruption
    > is still visible. The screen is properly restored by a manual VT switch.
    > The corruption is clearly related to the existing background pixmap, as
    > moving the windows does not change its pattern. Oddly enough, starting a GL
    > app such as glxgears and moving it into and out of focus also properly
    > restores the screen.

    So what happens on 2.6.7 with swsusp1? Can you try vesafb (and fbdev
    Xserver)?

    Pavel
    --
    Horseback riding is like software...
    ...vgf orggre jura vgf serr.
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 14:04    [W:0.022 / U:0.260 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site