lkml.org 
[lkml]   [2004]   [May]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.6.6 "IDE cache-flush at shutdown fixes"
On Mon, 10 May 2004 23:59:32 +0200
Rene Herman <rene.herman@keyaccess.nl> wrote:

> Rene Herman wrote:
>
> > With this one, the cache flushing noise is no more, but still a problem
> > unfortunately. With or without these patches, 2.6.6 powers down the
> > drive during reboot. This is very annoying, seeing as how it immediately
> > needs to spin up again for POST.
>
> Sorry, mistaken. This only happens _with_ your change. Without, 2.6.6
> just complains.
>
> Rene.

I am having this "spin up" behaviour with plain 2.6.6 (I haven't tried any patches)

On reboot, after it suspended the drives, there is a roughly 15 second delay at post while the bios is initializing the hard disks. During this time the hard disk LED is lit.

Shut down and power up behaviour is normal, it's only on a reboot that the above occurs.

Hardware: Pentium4, Gigabyte motherboard, i845, ICH2 IDE controllers.
Disks: Two identical Maxtor 40 Gb 6E040L0 models. Primary master and primary slave. UDMA (100).

Note that I do hear a bit of a "cache flush" noise, but I assume that's normal because Windows XP makes that same noise when shutting down. It seems to be a normal hard disk sound.

I do not get any complaints like you have in the boot logs though. Everything is normal unless I reboot (and even that is just a trivial delay and probably not at all harmful)

Mike

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:03    [from the cache]
©2003-2011 Jasper Spaans