[lkml]   [2004]   [Apr]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [Patch 17/23] mask v2 = [6/7] nodemask_t_ia64_changes
    Several architectures have this large version of find_next_bit() code.

    It may well make sense for the O(1) scheduler to be inlining this.

    Perhaps these large versions should be renamed sched_find_next_bit(), as
    is done for sched_find_first_bit(), and another, more space efficient
    version provided under the name find_next_bit(), for use by others who
    should prefer smaller code size. The asm-generic version of this
    smaller one might be something like [pseudo C]:

    int find_next_bit(addr, size, pos)
    int i;
    for (i = pos; i < size; i++) {
    if (test_bit(i, addr))
    return i;

    Arch's that have a reasonably tight version of find_next_bit() already
    could use it for both sched_find_next_bit() and find_next_bit().

    Just speculating ...

    I won't rest till it's the best ...
    Programmer, Linux Scalability
    Paul Jackson <> 1.650.933.1373
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:02    [W:0.020 / U:34.864 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site