[lkml]   [2004]   [Apr]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] mask ADT: new mask.h file [2/22]
Paul Jackson wrote:
> Nick wrote:
>>I like cpumask_t.
> Ok - one vote for cpumask_t.
> I could go either way. I see that 'struct foo' is more common than
> 'foo_t' in kernel code.
> I will not actually propose to change cpumask_t to 'struct cpumask'
> unless others want it. Without a half-way decent reason, it would just
> be stupid churning. But I wouldn't put up much resistance to such a
> change.

I think Linus likes keeping struct around if something is
a collection of items both conceptually and in its usage.
And prefers typedefs for things that are single entities
outside their implementation.

>>And you should not need to look inside it or use it with
>>anything other than using the cpumask interface, right?
> In my view, right - you (seldom) need to look inside. From what I can
> make of Rusty's statements so far, he apparently has a different view ;).

I prefer your complete API. I don't think there is any point
doing the abstraction at all if you only have half the API.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:02    [from the cache]
©2003-2011 Jasper Spaans