lkml.org 
[lkml]   [2004]   [Apr]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRE: Error compiling kernel 2.6.4 with dpt_i2o driver
Date
From
This is the `2.4.2->2.6.5' driver source tarball I have that is close to the set of patches I submitted in February in linux-scsi. It should work *much* better.

Sincerely -- Mark Salyzyn

-----Original Message-----
From: Marc-Christian Petersen [mailto:m.c.p@kernel.linux-systeme.com]
Sent: Saturday, April 17, 2004 11:37 AM
To: linux-kernel@vger.kernel.org
Cc: Vágási László; Salyzyn, Mark
Subject: Re: Error compiling kernel 2.6.4 with dpt_i2o driver
On Saturday 17 April 2004 17:27, Vágási László wrote:

Hi Vágási,

> My company is running a Degian GNU Linux on a dual Intel PII 933MHz
> system with 1 GB RAM.
> Currently it is running kernel 2.4.22 which supports our Adaptec 2100S
> raid controller using the dpt_i2o driver.
>
> We decided to change to kernel 2.6.x (I have tried 2.6.0, 2.6.1, 2.6.4)
> but it fails to compile.
> Here are some lines from the output:
> drivers/scsi/dpt_i2o.c:32:2 #error Please convert me to
> Documentation/DMA-mapping.txt
> drivers/scsi/dpt_i2o.c: In function 'adpt_install_hba':
> drivers/scsi/dpt_i2o.c:997: warning: passing arg 2 of 'request_irq' from
> incompatible pointer type
> drivers/scsi/dpt_i2o.c: I function 'adpt_scsi_to_i25':
> drivers/scsi/dpt_i2o.c:2118: structure has no member named 'address'
> drivers/scsi/dpt_i2o.c: At top level:
> drivers/scsi/dpt_i2o.c:165: warning: 'dptids' defined but not used

http://www.kernel.org/pub/linux/kernel/people/mcp/2.6-WOLK/linux-2.6.4-wolk2.0-broken-out/2203_adaptec_dpt_i2o.patch

Mark: Is there a newer one which applies to 2.6.5/2.6.6-rc1||-bk*?
ciao, Marc
[unhandled content-type:application/x-compressed]
\
 
 \ /
  Last update: 2005-03-22 14:02    [from the cache]
©2003-2011 Jasper Spaans