lkml.org 
[lkml]   [2004]   [Mar]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Is there some bug in ext3 in 2.4.25?

    Hi,

    This sounds like memory corruption (which could be caused by a misbehaving
    driver or by flaky hardware) because transaction->t_ilist is not used at
    all by the kernel code. Did this box run stable with other kernels?

    I found a similar report from Michelle (CCed), which can be found at:
    http://marc.theaimsgroup.com/?l=linux-kernel&m=107529754608448&w=2

    Searching a bit more, I found another message from Michelle with
    topic "[SOLVED] Kernel-Bug (at checkpoint.c 587)"
    http://lists.debian.org/debian-user-german/2004/debian-user-german-200401/msg04404.html

    Unfortunately the said message is in German, which I can't understand.
    Michelle, can you clarify it for me?

    Stephen, Andrew, any idea how can transaction->t_ilist become not NULL?


    On Thu, 4 Mar 2004, Daniel Fenert wrote:

    > Message from syslogd@lazy at Thu Mar 4 08:31:58 2004 ...
    > lazy kernel: Assertion failure in __journal_drop_transaction() at
    > checkpoint.c:587: "transaction->t_ilist == NULL"
    >
    > Networking still works, I've tried to login, but no luck here.
    > I've got one ssh console opened, and tried to reboot, but nothing happend, it
    > looks like it lost connection with hda :(
    > Where should I look for reason?
    > Machine as faaar away, and it's second or third time it hangs mysteriously,
    > the only difference is that this time I've got some console output.
    >

    From daniel@fenert.net Fri Mar 5 10:48:26 2004
    Date: Thu, 4 Mar 2004 08:03:29 +0100
    From: Daniel Fenert <daniel@fenert.net>
    To: linux-kernel@vger.kernel.org
    Subject: Re: Is there some bug in ext3 in 2.4.25?

    >Message from syslogd@lazy at Thu Mar 4 08:31:58 2004 ...
    >lazy kernel: Assertion failure in __journal_drop_transaction() at
    >checkpoint.c:587: "transaction->t_ilist == NULL"

    One more thing - it has happened when /var got full.


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 14:01    [W:0.024 / U:0.588 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site