[lkml]   [2004]   [Mar]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: (usagi-users 02870) Re: IPv6 multicast in 2.4.25 broken?
    On Tue, Mar 30, 2004 at 01:47:06PM -0800, thus spake David Stevens:
    > Can you reproduce this in a small test program and send me
    > the source? Also, the contents of /dev/proc/igmp6 and any
    > arguments you ran the program with would be helpful.

    Not at this time, as I would have to reinstall a 2.4.25 kernel. But I
    plan to do the testing soon.

    > At first I thought it might be that you have an MLD-snooping
    > switch that doesn't understand MLDv2 packets, but ff02::1 is
    > the all-nodes address which all hosts join, and which is not
    > advertised at all. That should work if you're receiving any
    > multicasts at all.

    Well, I see those packets with tcpdump on both the sending and receiving
    interfaces, so no ethernet equipment is involved. Moreover, the same
    code works perfectly on 2.4.24, which should indicate that there are
    some changes between the two (more precisely between 2.4.24 and
    2.4.25-pre4) that break something. Somehow the multicast packets are
    received but not relayed to the socket...

    "The whole problem with the world is that fools and fanatics are
    always so certain of themselves, and wiser people so full of doubts."
    - Bertrand Russell
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:02    [W:0.020 / U:9.196 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site